Incident
Incident Report for 2BM SMS
Resolved
We found the flaw and fixed it
Posted Oct 30, 2017 - 19:43 CET
Investigating
We are currently investigating this issue.
Posted Oct 30, 2017 - 13:36 CET